Google

23 апр. 2015 г.

Ubuntu 14.04: несовместимость Nvidia и Wine

В Ubuntu 14.04 сталкнулся с такой проблемой: после установки драйверов Nvidia не мог установить ни одну из версий Wine. При установке Wine возникала ошибка следующего плана:
The following packages will be REMOVED:
  nvidia-libopencl1-331-updates
Проблема связана с пакетом ibOpenCL.so, который необходим для установки wine и nvidia. Описание бага можно найти тут.
Для решения данной проблемы нужно сделать следующее:

1. Установить nvidia-cuda-toolkit:
sudo apt-get install nvidia-cuda-toolkit
2. Установить пакет ocl-icd-opencl-dev:
sudo apt-get install ocl-icd-opencl-dev
3. Установить  wine:
sudo apt-get install wine



22 апр. 2015 г.

Ubuntu 14.04: запускаем Gimp в однооконном режиме.

В версии Gimp 2.8 был добавлен однооконный режим, который по умолчанию отключен. Для того, чтобы включить этот самый режим необходимо в меню выбрать Windows (окна), затем Single-Window Mode (однооконный режим). 

17 апр. 2015 г.

Gradle: установка последней версии в Ubuntu

Для установки последней стабильной версии Gradle в Ubuntu необходимо:

1. Скачать с официального сайта последнюю версию.

2. Скачанный архив распаковать в любое удобное место, например в:
/home/myUser/dev/gradle-2.3
3. Добавить в файл /home/myUser/.bashrc следующие строки:
#### Gradle options ###
export GRADLE_HOME=/home/myUser/dev/gradle-2.3
export PATH=$PATH:$GRADLE_HOME/bin
Не забываем сохранить файл /home/myUser/.bashrc после изменений. Также необходимо закрыть терминал (консоль) и запустить его снова.

 4. После чего проверяем работоспособность gradle. Для  этого в консоли вводим команду:
gradle -v
Результат должен быть примерно таким:
------------------------------------------------------------
Gradle 2.3
------------------------------------------------------------

Build time:   2015-02-16 05:09:33 UTC
Build number: none
Revision:     586be72bf6e3df1ee7676d1f2a3afd9157341274

Groovy:       2.3.9
Ant:          Apache Ant(TM) version 1.9.3 compiled on December 23 2013
JVM:          1.7.0_80 (Oracle Corporation 24.80-b11)
OS:           Linux 3.13.0-49-generic amd64

Также Gradle можно установить с помощью утилиты SdkMan(The Software Development Kit Manage)


Social